Project

General

Profile

Bug #10456

Erreur à la validation du formulaire si on indique une date de fin de publication

Added by David Lesimple 3 months ago. Updated 2 months ago.

Status:
Closed
Priority:
High
Target version:
-
Start date:
02/13/2019
Due date:
% Done:

100%

Estimated time:
Navigateur:
Tous
Votre version de Silverpeas:
6.1-x
Operating System:
Votre base de données:
Toutes

Description

Sur une plateforme multilangue, si on est en Anglais et qu'on indique une date et une heure pour la fin de publication d'une actu,
il y a une popup d'erreur.

Date indiquée au format Anglais comme l'IHM le demande.

MM/DD/YYYY HH:MM

History

#1

Updated by David Lesimple 3 months ago

10:42:21,411 SEVERE [silverpeas.silvertrace.util] (default task-154) Error uploading files. : org.silverpeas.core.exception.UtilException: Error uploading files
        at org.silverpeas.core.util.file.FileUploadUtil.parseRequest(FileUploadUtil.java:72)
        at org.silverpeas.core.web.http.HttpRequest.getFileItems(HttpRequest.java:131)
        at org.silverpeas.components.quickinfo.servlets.QuickInfoRequestRouter.saveQuickInfo(QuickInfoRequestRouter.java:212)
        at org.silverpeas.components.quickinfo.servlets.QuickInfoRequestRouter.getDestination(QuickInfoRequestRouter.java:100)
        at org.silverpeas.components.quickinfo.servlets.QuickInfoRequestRouter.getDestination(QuickInfoRequestRouter.java:47)
...
Caused by: org.apache.commons.fileupload.FileUploadBase$InvalidContentTypeException: the request doesn't contain a multipart/form-data or multipart/mixed stream, 
 content type header is application/x-www-form-urlencoded
        at org.apache.commons.fileupload.FileUploadBase$FileItemIteratorImpl.<init>(FileUploadBase.java:948)
        at org.apache.commons.fileupload.FileUploadBase.getItemIterator(FileUploadBase.java:310)
        at org.apache.commons.fileupload.FileUploadBase.parseRequest(FileUploadBase.java:334)
        at org.apache.commons.fileupload.servlet.ServletFileUpload.parseRequest(ServletFileUpload.java:115)
        at org.silverpeas.core.util.file.FileUploadUtil.parseRequest(FileUploadUtil.java:70)

#2

Updated by Nicolas Eysseric 3 months ago

  • Status changed from New to In progress...
  • Assignee set to Nicolas Eysseric
#3

Updated by Nicolas Eysseric 3 months ago

  • Status changed from In progress... to Resolved
  • % Done changed from 0 to 100
#4

Updated by Miguel Moquillon 2 months ago

  • Status changed from Resolved to Integration in progress...
#5

Updated by Miguel Moquillon 2 months ago

  • Status changed from Integration in progress... to Closed

Also available in: Atom PDF