Project

General

Profile

Actions

Bug #11585

closed

Affichage des résultats très lent

Added by David Lesimple over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Start date:
06/23/2020
Due date:
% Done:

100%

Estimated time:
Navigateur:
Tous
Votre version de Silverpeas:
6.1
Système d'exploitation:
Votre base de données:
Toutes
Livraison en TEST:
Livraison en PROD:

Description

Lorsque plusieurs centaines d'utilisateurs répondent à une enquête comportant une bonne dizaine de questions (ou plus)
l'affichage des résultats est très long, à minima 30" et peut même ne pas s'afficher si on atteint un timeout défini au niveau http.

Actions #2

Updated by Nicolas Eysseric over 1 year ago

  • Status changed from New to In progress...
  • Assignee set to Nicolas Eysseric
  • Target version set to Version 6.1.1
Actions #3

Updated by Nicolas Eysseric over 1 year ago

  • Status changed from In progress... to Resolved
  • % Done changed from 0 to 100

Pour une enquête de 25 questions et près de 800 participants, passage de 2'10" à 30".
Le temps restant est celui nécessaire au navigateur pour afficher la (très) longue page.
Ce point sera amélioré lors d'une refonte poussée de l'application.
Un message d'attente a été mis en place également...

A noter que, pour plus de clarté, les participants n'ayant pas répondu à une question ouverte ne sont plus affichés. Auparavant, il était écrit "Aucune réponse".

Traité par PR :
Actions #4

Updated by Miguel Moquillon about 1 year ago

  • Status changed from Resolved to Integration in progress...
Actions #5

Updated by Miguel Moquillon about 1 year ago

  • Status changed from Integration in progress... to Closed

Intégré dans la branche 6.1.x et dans master.

Pour info, avec plus de 2000 réponses à une centaine de questions pour une enquête, je n'ai pas rencontré vraiment de pb de performances avant correction. Il m'a été donc difficile de valider un quelconque gain de perfs.

Actions

Also available in: Atom PDF