Project

General

Profile

Actions

Bug #13057

open

Dans certains cas, silverpeas configure indique OK alors que la configuration s'est mal passée.

Added by David Lesimple 5 months ago.

Status:
New
Priority:
Normal
Target version:
-
Start date:
05/16/2022
Due date:
% Done:

0%

Estimated time:
Navigateur:
Tous
Votre version de Silverpeas:
6.2.3
Système d'exploitation:
Votre base de données:
Toutes
Livraison en TEST:
Livraison en PROD:

Description

Quand on utilise un .cli dans configuration/jboss et le mode batch
silverpeas configure indique [OK] même quand il y a une erreur :

Seule la consultation du build*.log permet de savoir qu'il y a un problème.

Exemple:

 16:16:47.892684 [install] Invalid resource. Execution Output:
Secure Wildfly (is wildfly after a secured reverse proxy?): true
{"outcome" => "success"}
{"outcome" => "success"}
{"outcome" => "success"}
The batch failed with the following error (you are remaining in the batch editing mode to have a chance to correct the error):
WFLYCTL0062: Composite operation failed and was rolled back. Steps that failed:
Step: step-1
Operation: /subsystem=logging/logging-profile=silverpeas/size-rotating-file-handler=WKF_ARCHIVER_LOG_FILE:add(level="INFO",suffix=".yyyy.MM.dd.hh.mm.ss", file={"path"=>"${env.SILVERPEAS_HOME}/data/log/akwel-workflow-archiver.log"},$
Failure: WFLYCTL0212: Duplicate resource [
    ("subsystem" => "logging"),
    ("logging-profile" => "silverpeas"),
    ("size-rotating-file-handler" => "WKF_ARCHIVER_LOG_FILE")
]
...
16:16:52.29177 [configure] Configure: [OK]

No data to display

Actions

Also available in: Atom PDF