Project

General

Profile

Actions

Bug #1684

closed

Non prise en compte de l'ajout d'un utilisateur à un groupe

Added by Pierre TEISSONNIERE almost 11 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
High
Category:
Administration
Start date:
01/18/2012
Due date:
01/18/2012
% Done:

100%

Estimated time:
Spent time:
Navigateur:
Tous
Votre version de Silverpeas:
5.5
Système d'exploitation:
Votre base de données:
Toutes
Livraison en TEST:
Livraison en PROD:

Description

Sur un groupe : Que voulez-vous faire ? Modifier la liste des utilisateurs
Si l'on passe ensuite par Que voulez-vous faire ? Rechercher un utilisateur -> On coche un utilisateur, on valide mais le groupe n'est pas mis à jour.

Si l'on passe par Que voulez_vous faire ? Naviguer dans l'arborescence -> On coche un utilisateur, on valide, le groupe est mis à jour.

Malheureusement, la plupart de nos utilisateurs passent par la fonction "Rechercher un utilisateur".

Pour être précis, les tests ont été effectués sur la version 5.5.2


Related issues

Precedes Silverpeas Core - Bug #2665: Non prise en compte de l'ajout d'un groupe dans un rôleClosedMiguel Moquillon01/19/201201/19/2012

Actions
Follows Silverpeas Core - Feature #2829: Nouveau panneau d'utilisateursClosedMiguel Moquillon01/17/2012

Actions
Actions #1

Updated by Pierre TEISSONNIERE almost 11 years ago

En complément, si l'on veux enlever un utilisateur du groupe :
On coche un utilisateur, Que voulez-vous faire ? Supprimer les éléments sélectionnés -> Le groupe n'est pas mis à jour (en tout cas, au niveau affichage). Si l'on valide, l'utilisateur est quand même supprimé du groupe.

Actions #2

Updated by Emmanuel Hugonnet almost 11 years ago

  • Status changed from New to Feedback

D'où viennent vos utilisateurs (domaine silverpeas, ldap) ?
Je ne reproduis pas votre problème pour l'ajout d'utilisateur.

Actions #3

Updated by Pierre TEISSONNIERE almost 11 years ago

Il s'agit d'utilisateurs du domaine Silverpeas. Je peux te donner un accès sur l'une des plateformes qui présente le problème.

Actions #4

Updated by David Lesimple almost 11 years ago

Bonjour, reproduit sur le plateforme d'un client en 5.4.2 :

- Si l'on passe par Rechercher un utilisateur -> On coche plusieurs utilisateurs, seul le premier coché est ajouté dans le groupe.

- Si l'on passe par Naviguer dans l'arborescence -> On coche plusieurs utilisateurs, ils sont bien ajoutés au groupe.

Actions #5

Updated by Pierre TEISSONNIERE almost 11 years ago

Comment fait-on ? Est-ce que je vous laisse voir entre vous ou est-ce que vous avez besoin d'un accès à l'une des plateformes qui présente le problème ?

Actions #6

Updated by Emmanuel Hugonnet almost 11 years ago

  • Status changed from Feedback to Resolved
  • Assignee set to Emmanuel Hugonnet
  • Target version set to Version 5.6
  • % Done changed from 0 to 100

J'ai nettoyé et simplifié le code, notamment avec une suppression immédiate des utilisateurs cochés.
Il semblerait que cela a fait disparaitre le bug

Actions #7

Updated by Nicolas Eysseric over 10 years ago

  • Status changed from Resolved to Closed

OK. Validé.

Actions #8

Updated by Alain SOULIER over 10 years ago

Bonjour,

Je rencontre exactement le même problème (ajout possible uniquement en passant par "naviguer dans l'arborescence". Suis en version 5.6, domaine Silverpeas.

Actions #9

Updated by Alban KARNAVOS about 10 years ago

  • Status changed from Closed to Re-opened
  • Assignee deleted (Emmanuel Hugonnet)
  • Target version deleted (Version 5.6)
  • % Done changed from 100 to 0

Bonjour,

Je ré-ouvre ce bug car il apparaît à nouveau sur une plateforme en 5.7.3, avec des utilisateurs Silverpeas.
Le comportement est identique à celui décrit par Pierre initialement.

Merci
Alban

Actions #10

Updated by Nicolas Eysseric almost 10 years ago

  • Category set to Administration
  • Target version set to Version 5.9
  • Navigateur changed from Firefox 3.x to Tous

Cette anomalie est identique à la #2665.
Ici, il s'agit des utilisateurs. Dans la #2665, ce sont les groupes.
Ce n'est "qu'un" problème d'interface graphique.

Actions #11

Updated by Nicolas Eysseric almost 10 years ago

  • Status changed from Re-opened to Assigned
  • Assignee set to Miguel Moquillon
Actions #12

Updated by Miguel Moquillon almost 10 years ago

  • Status changed from Assigned to Feedback

Je ne reproduit pas le problème avec la version 5.9-SNAPSHOT (5.9 en cours de développement)

Actions #13

Updated by Miguel Moquillon over 9 years ago

  • Status changed from Feedback to Resolved
Actions #14

Updated by Nicolas Eysseric over 9 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Avec la refonte globale du panneau d'utilisateurs (feature #2829), ce problème n'est plus d'actualité.

Actions

Also available in: Atom PDF