Project

General

Profile

Actions

Bug #2057

closed

Fichier non présent dans l'export

Added by yann delcambre over 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
High
Category:
Import/Export
Start date:
06/01/2011
Due date:
% Done:

100%

Estimated time:
Navigateur:
Firefox 4.x
Votre version de Silverpeas:
5.6
Système d'exploitation:
Votre base de données:
Toutes
Livraison en TEST:
Livraison en PROD:

Description

Lors de l'export de theme tracker, il arrive que des fichiers soit manquants.

Cela vient peut etre du chemin généré qi serait trop long, mais a ce moment les repertoires devraient passer en ID.

Pour avoir un exemple sur notre plateforme, contacter Mme. Clerc .


Files

IMG_101.jpg (13.9 KB) IMG_101.jpg Stéphanie Fariello, 07/13/2012 03:42 PM
IMG_102.jpg (20.3 KB) IMG_102.jpg Stéphanie Fariello, 07/13/2012 03:42 PM
IMG_103.jpg (21.8 KB) IMG_103.jpg Stéphanie Fariello, 07/13/2012 03:42 PM
Actions #1

Updated by Stéphanie Fariello over 9 years ago

Contact de Mme Clerc pour avoir plus d'information.

Actions #2

Updated by Stéphanie Fariello over 9 years ago

  • Status changed from New to Feedback

Attente du retour de Marie-Sophie CLERC

Actions #3

Updated by Stéphanie Fariello over 9 years ago

Bonjour,
Ce problème est il toujours existant dans la version actuelle ?

Actions #4

Updated by yann delcambre over 9 years ago

Contactez Mme Clerc pour plus d'information

Actions #5

Updated by Stéphanie Fariello over 9 years ago

Le problème est double :
- il manque les fichiers dans les publications lors de l'export
- et dans certains cas, il manque aussi les sous thèmes
Reproduit sur la plateforme client et sur notre intranet.

J'ai à disposition tous les éléments client (que je ne pose pas ici par soucis de confidentialité), les répertoires sont générés avec les id et non les noms.
Sur l'intranoo, je reproduit le problème du manque de certains sous thèmes et des fichiers, toutefois, dans ce cas, les répertoires sont générés avec le nom des thèmes.
Pour tests, il faut exporter le thème "Formation" (http://intranoo.oevo.com/silverpeas/Topic/498?ComponentId=kmelia91) de "Chez Silverpeas > Documentations > Formations"
Des erreurs sont générées lors de l'ouverture du fichier index.html

première :

seconde :

puis ce type de message pour tous les sous thèmes :

Dans l'export sur l'intranoo, le thème "Par client" contenant 17 sous thèmes et 32 publication n'est pas présent dans la restitution et il manque les contenus de toutes les publications.

Actions #6

Updated by Nicolas Eysseric over 9 years ago

  • Status changed from Qualified to In progress...
  • Assignee set to Nicolas Eysseric
Actions #7

Updated by Nicolas Eysseric over 9 years ago

  • Project changed from GED to Silverpeas Core
  • Category set to Import/Export
  • % Done changed from 0 to 70

Il y a en effet plusieurs problèmes.

Le premier est le non affichage de certains sous thèmes dans l'explorateur. Problème induit par les erreurs Javascript.
Ce point a été corrigé.

Sur notre intranet, un deuxième problème survenait si le nom d'un thème ou d'une publication contenait le caractère #.
Dans ce cas, le clic sur la publication générait une erreur 404 au lieu d'afficher la page HTML.
Ce point a également été corrigé.

Actions #8

Updated by Nicolas Eysseric over 9 years ago

  • Status changed from In progress... to Closed
  • Target version set to Version 5.10.1
  • % Done changed from 70 to 100

Le contenu des champs Wysiwyg des formulaires n'était pas exporté.

Actions

Also available in: Atom PDF