Project

General

Profile

Actions

Support #8777

closed

Frontal web apache SSH - erreur

Added by LNE Exploitation almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
High
Target version:
-
Start date:
05/05/2017
Due date:
% Done:

100%

Estimated time:
Navigateur:
Firefox
Votre version de Silverpeas:
5.15.5
Système d'exploitation:
Livraison en TEST:
Livraison en PROD:

Description

Bonjour,
je tente d'accéder à la plateforme silverpeas au travers d'un serveur apache en ssl.
J'ai suivi votre documentation Serveur HTTPS en frontal de Décembre 2015 avec l'architecture Extranet 2 - Frontal en https et Jboss en http.

Au niveau silverpeas j'ai configuré le fichier
opt/silverpeas/jboss-6.1.0.Silverpeas/server/default/deploy/jbossweb.sar/server.xml avec la ligne
<Connector URIEncoding="UTF-8" address="${jboss.bind.address}" port="${jboss.web.http.port}" protocol="HTTP/1.1" redirectPort="${jboss.web.https.port}" proxyPort="443" proxyName="www.urldite.fr&quot; scheme="https"/>

Comme expliqué je n'ai rien fait coté Silverpeas hormi la configuration de l'utl de l'application.

J'accéde bien à la page d'authentification du silverpeas mais une fois les identifiants rentrés, j'ai un message d'erreur sur la page
http://www.nomdusite.fr:443/silverpeas/Main/MainFrameSilverpeasV5.jsp
Failed to load ressource : ERR_INVALID_HTTP_REPONSE

Actions #1

Updated by LNE Exploitation almost 7 years ago

  • Project changed from 69 to Service Installation
  • Priority changed from Normal to High
Actions #2

Updated by David Lesimple almost 7 years ago

  • Status changed from New to Assigned
  • Assignee set to David Lesimple
Actions #3

Updated by David Lesimple almost 7 years ago

  • Status changed from Assigned to Feedback

Sur la page d'authentification, vous êtes bien en https ?

Actions #4

Updated by LNE Exploitation almost 7 years ago

  • Navigateur changed from Tous to Firefox

Bonjour,
Oui sur la page d'authentification nous sommes en https et cela fonctionne.
je viens de revérifier l'ensemble avec plusieurs test

En fait le problème viens du fait qu'une fois les identifiants saisies l'url généré est de type
http://monsite:443/silverpeas/Main/MainFrameSilverpeasV5.jsp

Internet explorer sait le géré et cela fonctionne
Par contre chrome et Firefox renvoi une erreur

pour firefox

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>400 Bad Request</title>
</head><body>
<h1>Bad Request</h1>
<p>Your browser sent a request that this server could not understand.<br />
Reason: You're speaking plain HTTP to an SSL-enabled server port.<br />
Instead use the HTTPS scheme to access this URL, please.<br />

Actions #5

Updated by David Lesimple almost 7 years ago

Bonjour,

Que valent les paramètres server.http.port, server.ssl et httpServerBase dans le fichier $SILVERPEAS_HOME/properties/org/silverpeas/general.properties ?

Actions #6

Updated by LNE Exploitation almost 7 years ago

Je n'ai rien modifié dans ce fichier

Voici les propriétes du fichier $SILVERPEAS_HOME/properties/org/silverpeas/general.properties

server.http.port =
server.ssl = false
httpServerBase =

Actions #7

Updated by David Lesimple almost 7 years ago

LNE Exploitation a écrit :

Je n'ai rien modifié dans ce fichier

Voici les propriétes du fichier $SILVERPEAS_HOME/properties/org/silverpeas/general.properties

server.http.port =
server.ssl = false
httpServerBase =

A priori, il faut mettre server.ssl à true
Merci de me confirmer pour que je modifie la documentation si nécessaire.

Actions #8

Updated by LNE Exploitation almost 7 years ago

c'est bon cela fonctionne sur l'ensemble des naviguateur en mettant le paramètre server.ssl = true dans le fichier
$SILVERPEAS_HOME/properties/org/silverpeas/general.properties

Actions #9

Updated by David Lesimple almost 7 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Merci pour le retour. Doc mise à jour sur l'extranet.

Actions

Also available in: Atom PDF