Project

General

Profile

Actions

Bug #1439

closed

Réinitialisation de mot de passe

Added by Sebastien Vuillet almost 11 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Category:
Authentification
Start date:
12/21/2010
Due date:
% Done:

100%

Estimated time:
Navigateur:
Tous
Votre version de Silverpeas:
5.7.1
Système d'exploitation:
Linux
Votre base de données:
PostgreSQL
Livraison en TEST:
Livraison en PROD:

Description

La réinitialisation de mot de passe ne fonctionne pas (voir screenshot).


Files

Capture.png (32.1 KB) Capture.png Sebastien Vuillet, 12/21/2010 12:01 PM
erreur_reinit.jsp.jpg (145 KB) erreur_reinit.jsp.jpg David Lesimple, 09/20/2011 11:08 AM
15.png (114 KB) 15.png Sebastien Vuillet, 06/04/2012 05:35 PM
Actions #1

Updated by Nicolas Eysseric almost 11 years ago

  • Category set to Authentification
Actions #2

Updated by Nicolas Eysseric over 10 years ago

  • Status changed from New to Feedback

Le changement de mot de passe fonctionne bien.
Toutefois, je reproduis le problème décrit ici uniquement si l'utilisateur qui demande la réinitialisation de son mot de passe ne dispose pas d'adresse email.
Sébastien, est-ce le cas lors de ton test ?

Actions #3

Updated by Sebastien Vuillet over 10 years ago

C'est probable, mais je ne peux pas l'assurer avec certitude (5 mois sont passé depuis)...

Actions #4

Updated by David Lesimple about 10 years ago

Je reproduis ce pb en 5.7.1 avec la connexion anonyme activée, l'erreur survient donc lorsqu'on
clique sur le lien Réinitialiser mon mot de passe...

Reproduit avec skin SilverpeasLight.
Voir PJ.
De plus, après le 404, Silverpeas est rechargé dans myMain au lieu de l'etre dans le frameset principal.

Actions #5

Updated by Nicolas Eysseric almost 10 years ago

Je ne reproduis pas ce problème en v5.9-SNAPSHOT.
Je pense qu'il ne se produit pas non plus en v5.8.

Actions #6

Updated by Stéphanie Fariello over 9 years ago

Ce bug est il toujours d'actualité en 5.9 ?

Actions #7

Updated by Sebastien Vuillet over 9 years ago

Je l'ai reproduit sur un 5.9.
Voir capture d'écran.

Actions #8

Updated by Stéphanie Fariello over 9 years ago

  • Status changed from Feedback to Qualified

Le problème n'est pas reproduit en 5.9.1 sur l'Intranoo.

Je le reproduit en local, en 5.9, même avec un utilisateur ayant une adresse mail
Toutefois, le problème est bien lié au mail, dans les traces j'ai :
ERROR : forgottenPassword.EX_SEND_MAIL | MODULE : peasCore.CredentialsServlet.forgottenPasswordError() | !!! Message forgottenPassword.EX_SEND_MAIL NOT INITIALIZED !!! (EXCEPTION : javax.mail.MessagingException: Unknown SMTP host: zimbra.silverpeas.com;
nested exception is:
java.net.UnknownHostException: zimbra.silverpeas.com

Le bug est donc plus lié à une mauvaise explication de l'erreur.

Actions #9

Updated by Nicolas Eysseric over 9 years ago

  • Status changed from Qualified to Closed
  • Assignee set to Nicolas Eysseric
  • Target version set to Version 5.10.1
  • % Done changed from 0 to 100
Cette erreur se produisait dans l'un des deux cas suivants :
  • L'utilisateur qui souhaite réinitialiser son mot de passe n'a pas d'adresse mail
  • La plate-forme ne peut pas envoyer de mail (à cause d'une mauvaise configuration)

Désormais, dans ces deux cas, l'utilisateur est redirigé vers une page lui précisant La réinitialisation de votre mot de passe est impossible. Veuillez contacter votre administrateur...

Actions

Also available in: Atom PDF