Project

General

Profile

Support #7259

Impossible d'attribuer des doits à des sous-groupes

Added by Umar Raad over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
Administration
Target version:
-
Start date:
12/27/2015
Due date:
% Done:

0%

Estimated time:
Navigateur:
Tous
Votre version de Silverpeas:
5.15
Système d'exploitation:

Description

Bonjour,

J'ai créer plusieurs groupes dans le domaine Silverpeas
Dans ces groupes j'ai créé des sous groupes.

Lorsque j'utilise l'interface de gestion des droits pour appliquer des droits sur une application et que je veux choisir un groupe, seul les groupes de premier niveau apparaissent. Aucun des sous-groupes n'est affiché et je n'ai pas trouvé de moyen pour les faire apparaître.

Exemple:

On crée les groupes suivant:

Domaine Silverpeas: |-Groupe1 | |_GroupeA | |-Groupe2 |_GroupB

Seuls les groupes 1 et 2 sont disponibles pour l'attribution des droits. Les groupes A et B sont innaccessibles.


Files

groupes.jpg (3.04 KB) groupes.jpg Umar Raad, 12/27/2015 06:39 PM
groupError1.jpg (33.4 KB) groupError1.jpg Umar Raad, 01/08/2016 10:15 AM
groupError2.jpg (72.3 KB) groupError2.jpg Umar Raad, 01/08/2016 10:16 AM
groupes.png (127 KB) groupes.png David Lesimple, 01/12/2016 05:05 PM
#1

Updated by Umar Raad over 4 years ago

Hum... L'exemple aurait du être une arborescence comme dans l'image En pièce jointe

#2

Updated by Nicolas Eysseric over 4 years ago

  • Tracker changed from Bug to Support
  • Category set to Administration
  • Status changed from New to Feedback

Nous ne reproduisons pas ce problème.
Etes-vous certain que l'upgrade vers la 5.15 s'est bien passé ?

#3

Updated by Umar Raad over 4 years ago

Bonjour,

Peut-être que je fais une fausse manipulation quelque part.

Voici ma situation exacte (Voir la pièce jointe 1)

- Dans le domaine Silverpeas j'ai créé un groupe "Parent" qui s'appelle allgroups
- Ce groupe contien une série de sous-groupes
- chaque sous-groupe contient des utilisateurs

Lorsqu'on veut attribuer des droits sur une publication ce que je décrit ci-dessous se produit (Voir la pièce jointe 2)

- Les groupes "par défaut" et de premier niveau s'affichent
- Lorsque je clique sur un de ces groupes ses membres (utilisateurs) et les membres des sous-groupes (utilisateurs) apparaissent mais je ne vois pas la possibilité d'afficher ou de sélectionner un sous-groupe.

Avec les screenshots cela devient un peu plus clair,

Merci pour votre aide.

Umar

#4

Updated by David Lesimple over 4 years ago

Oui je ne vois pas pourquoi vous ne pouvez pas ajouter un groupe dans le role voulu. voir PJ.

#5

Updated by Umar Raad over 4 years ago

Bonjour,

Un soucis de plus en moins... Le problème (et par éa même occasion la solution) est le même que pour le bug https://tracker.silverpeas.org/issues/7382#change-32904
C'était lié à l'utilisation d'un reverse proxy qui ne passait pas les host header.

Depuis qu'il a été reconfiguré pour passer ces fameux headers, le problème ne se produit plus.

Merci encore pour votre aide et désolé de vous avoir fait perdre du temps.

Cordialement,

Umar

#6

Updated by Umar Raad over 4 years ago

  • Status changed from Feedback to Closed

J'ai oublié de clore le ticket. Voilà qui est fait.

Sorry

Also available in: Atom PDF